Apa Itu Load Balancing Mikrotik

Dalam komputasi, Load Balancing Mikrotik mengacu pada proses pendistribusian sekumpulan tugas ke sekumpulan sumber daya (unit komputasi), dengan tujuan membuat pemrosesan keseluruhannya lebih efisien. Teknik load balancing dapat mengoptimalkan waktu respons untuk setiap tugas, menghindari overloading node komputasi yang tidak merata sementara node komputasi lainnya tidak digunakan.

Load Balancing adalah subjek penelitian di bidang komputer paralel. Ada dua pendekatan utama: algoritma statis, yang tidak memperhitungkan keadaan mesin yang berbeda, dan algoritma dinamis, yang biasanya lebih umum dan lebih efisien, tetapi memerlukan pertukaran informasi antara unit komputasi yang berbeda, dengan risiko a hilangnya efisiensi.

Bagi sebagian besar orang di seluruh dunia, internet memegang kendali tertinggi dalam hidup kita. Kita menjadi semakin bergantung pada internet dan tetap terhubung untuk sebagian besar hari telah menjadi hal yang biasa. Dengan jumlah bisnis online yang meningkat setiap hari dan semakin banyak orang yang memilih untuk bekerja dari rumah, kebutuhan akan koneksi internet yang andal selalu tinggi.

Tetap terhubung dan menghindari waktu henti menjadi penting karena waktu henti menyebabkan kerugian finansial yang besar bagi bisnis dan individu. Pada artikel ini kami memperkenalkan konsep, pentingnya dan manfaat load balancing untuk internet.

Mari kita mulai dengan pemahaman yang jelas tentang arti sebenarnya dari internet load balancing. Jaringan komputer merutekan miliaran paket data secara harfiah setiap detik. Agar data ini dapat dirutekan secara efisien, jaringan perlu beroperasi dengan efisiensi optimal. Masukkan teknik load balancing sebagai solusi ideal untuk membantu jaringan beroperasi lebih efisien. Melalui pemerataan pemrosesan dan lalu lintas di seluruh jaringan, teknologi memastikan bahwa satu media tunggal tidak dikenakan pajak berlebih.

Server web Internet menggunakan teknologi distribusi beban untuk membantu pemerataan lalu lintas di berbagai server. Apa yang dicapai ini adalah penggunaan bandwidth yang tersedia secara lebih efisien. Ada peningkatan efisiensi yang menghasilkan akses lebih cepat ke banyak situs web yang dihosting oleh server web.

Penyeimbangan beban internet dilakukan dengan salah satu dari dua cara: masuk dan keluar. Mari kita periksa setiap jenis secara individual untuk lebih memahami bagaimana fungsinya. Penyeimbangan masuk mendukung banyak server tetapi untuk semua tampilan eksternal hanya muncul sebagai satu sistem. Teknik load balancing untuk lalu lintas masuk menggunakan DNS dinamis melalui salah satu dari dua cara. Ini dapat dimasukkan ke dalam sistem atau disediakan melalui layanan eksternal. Manfaat untuk membuatnya terpasang ke dalam sistem adalah penghematan biaya dan kontrol yang lebih baik.

Menyeimbangkan lalu lintas masuk memproses lalu lintas dari pengguna jarak jauh. Melalui penggunaan beberapa server, ini membantu meningkatkan bandwidth, menyediakan konektivitas yang lebih baik dan waktu henti yang rendah. Metode ini membantu meningkatkan efisiensi proses pengambilan informasi.

Teknologi outbound balancing secara khusus membantu proses distribusi lalu lintas secara merata dan efisien melalui jaringan. Ini membantu untuk memenuhi tujuan konektivitas dan kinerja kecepatan tinggi untuk pengguna global.

Distribusi beban untuk lalu lintas keluar menawarkan beberapa manfaat termasuk konektivitas yang praktis tanpa gangguan, peningkatan efisiensi bandwidth dan kemampuan untuk menggunakan beragam teknologi internet. Selain itu, dimungkinkan untuk menerapkan opsi load balancing yang fleksibel.

Untuk meringkas, pemerataan pemrosesan dan aktivitas komunikasi di seluruh jaringan untuk meminimalkan satu server yang kelebihan beban adalah tujuan utama dari penyeimbangan beban internet. Pendekatan alternatif ini membantu meningkatkan kinerja situs web yang sibuk dengan proses yang cukup sederhana yaitu meningkatkan server web yang digunakan. Ketika lalu lintas didistribusikan secara merata di sekumpulan server ujung belakang, efisiensi situs meningkat pesat.

Load Balancing Mikrotik NTH

Seiring dengan perkembangan teknologi lebih-lebih dalam bidang internet, banyak sekali bermunculan Internet Provider (ISP). Dan tidak mampu dipungkiri untuk pas ini keperluan akan internet merupakan sebuah keperluan yang pokok. Mulai dari akses Info hingga jual-beli online sudah jadi hal biasa.

Karena didorong oleh banyaknya permintaan dari penduduk akan koneksi internet, maka banyak perusahaan internet provider berlomba-lomba beri tambahan fasilitas dan juga produk yang terbaik. Dan tak khayal pas ini banyak tawaran untuk koneksi internet dengan harga yang makin terjangkau.

Dan bahkan mungkin di antara kita juga ada yang berlangganan pelayanan internet lebih dari satu provider. Nah, dengan multiple gateway ini lumayan penting dalam segi management agar koneksi internet yang kita miliki mampu terjadi secara optimal untuk masing-masing link. Salah satu metode yang paling banyak digunakan adalah dengan cara load balace. Dari load balance sendiri ada beberpa mekanisme yang mampu digunakan pada lain ECMP (Equal-Cost Multiple Path), NTH, PCC (Per-Connection Classifier).

Pada artikel pada mulanya sudah kita bahas metode ECMP & PCC, dan agar lebih lengkap kali ini kita akan mengkaji tentang load balance dengan NTH.

Apa itu NTH?

Load Balacing Mikrotik NTH sendiri adalah sebuah fitur terhadap firewall yang digunakan sebagai penghitung (counter) dari paket knowledge atau koneksi (packet new). Ada dua parameter utama dari NTH ini, yakni “Every” dan “Packet”.

“Every” merupakan parameter penghitung (counter) sedangkan “Packet” adalah penunjuk paket keberapa rule dari NTH ini akan dijalankan. Dengan demikian pemanfaatan NTH ini dilakukan denganmengaktifkan counter terhadap mangle, lantas ditandai dengan ‘Route-Mark’. Sehingga dengan route mark ini digunakan sebagai basic untuk menyebabkan policy route.

Konfigurasi NTH

Kita akan mencoba melaksanakan konfigurasi load balance mengfungsikan metode NTH. Seperti terhadap topologi di bawah ini, kita miliki dua gateway untuk koneksi ke internet.

Berdasarkan mekanisme NTH, untuk topologi diatas setiap trafik/paket knowledge yang lewat akan dibagi jadi 1 dan 2. Kemudian untuk link ISP-A akan digunakan untuk jalan paket 1 dan link ISP-B akan digunakan untuk jalan paket 2.

Langkah, pertama kita akan buat rule mangle lebih-lebih dahulu untuk menyebabkan routing-mark berdasarkan parameter NTH. Masuk ke menu IP –> Firewall –> Mangle. Tambahkan rule seperti berikut.

/ip firewall mangle

add action=mark-connection chain=prerouting in-interface=ether5 new-connection-mark=conn-1 nth=2,1

add action=mark-connection chain=prerouting in-interface=ether5 new-connection-mark=conn-2 nth=2,2

add action=mark-routing chain=prerouting connection-mark=conn-1 new-routing-mark=jalur-1 passthrough=no

add action=mark-routing chain=prerouting connection-mark=conn-2 new-routing-mark=jalur-2 passthrough=no

Setelah menyebabkan mangle, kita akan mengatur policy routing untuk pilih jalan trafik ke masing-masing gateway.

/ip route

add distance=1 gateway=172.16.1.1 routing-mark=jalur-1

add distance=1 gateway=192.168.1.1 routing-mark=jalur-2

add distance=1 gateway=172.16.1.1,192.168.1.1

Pada routing diatas terdapat 3 default gateway. Untuk gateway baris 1 dan 2 merupakan gateway untuk trafik dari LAN di ether5, sedangkan baris ke 3 merupakan gateway untuk trafik tidak cuman dari LAN (misal, trafik local process).

Load Balancing Mikrotik ECMP

Dengan banyaknyak metode load balance, kadang kita bingung ingin gunakan metode yang mana. Terlebih lagi banyak metode yang cuma bersama lihat konfigurasinya saja, kita dibuat pusing. Kali ini kita bakal coba tips load balance yang memadai enteng di dalam perihal konfigurasi dan benar-benar menarik untuk dicoba. Load balance bersama metode ECMP, yang merupakan improvisasi dari metode round robin load balance.  Load balance sendiri merupakan tehnik untuk mengkombinasikan koneksi internet lebih dari satu, umpama topologi :

Kita coba bahas load balance bersama 2 koneksi internet. Setting awal mirip seperti kita setting router agar router dan client di bawah router bisa terkoneksi ke internet. Karena ada dua koneksi internet, maka bakal ada 2 rule NAT masquerade.

Setelah konfigurasi standart koneksi ke internet selesai, sesudah itu kita bisa mulai setting Load balancing Mikrotik ECMP. Caranya memadai mudah, tinggal tambahkan rule default gateway bersama dst-address = 0.0.0.0 dan gateway=ISP-A,ISPB

ECMP merupakan “persistent per-connection load balancing” atau “per-src-dst-address combination load balancing”. Begitu salah satu gateway unreachable atau terputus, check-gateway bakal menonaktifkan gateway berikut dan gunakan gateway yang tetap aktif, agar kita bisa mendapatkan effect failover.

Jika kita mempunyai line/koneksi internet yang berbeda kecepatan bandwidth, kita bisa membawa dampak perbandingan untuk membagi beban. Misalkan kita mempunyai bandiwdth 2 MBps dan 8 Mbps. Jika kita membuat perbandingan, bakal jadi 1:4.

Dengan terdapatnya lebih dari satu gateway, kadang-kadang membawa dampak persoalan baru terhadap router, ke gateway mana router bakal terkoneksi. Kasusnya adalah saat ada paket masuk ke router (incoming) yang berasal dari luar (Internet), trafik respons dari router (outgoing) bakal terkena loadbalance juga. Sehingga paket tanggapan untuk request yang diterima dari interface WAN 1, bisa jadi dikirim melalui interface WAN 2. Untuk menjauhkan perihal tersebut, kita wajib membawa dampak ketetapan routing agar koneksi outgoing router tetap melalui interface yang mirip bersama interface trafik incomingnya.

/ip firewall mangle

add chain=input in-interface=ether1-ISP-A action=mark-connection new-connection-mark=ISP-A_conn

add chain=input in-interface=ether2-ISP-B action=mark-connection new-connection-mark=ISP-B_conn

add chain=output connection-mark=ISP-A_conn action=mark-routing new-routing-mark=ke_ISP-A

add chain=output connection-mark=ISP-B_conn action=mark-routing new-routing-mark=ke_ISP-B

/ip route

add dst-address=0.0.0.0/0 gateway=10.0.0.1 routing-mark=ke_ISP-A

add dst-address=0.0.0.0/0 gateway=172.16.0.1 routing-mark=ke_ISP-B

Permasalahan yang serng timbul adalah saat kita laksanakan setting bersama DNS salah satu ISP, maka saat ISP berikut down, koneksi DNS ke ISP kedua tidak berjalan. Untuk mengatasi perihal tersebut, kita bisa gunakan open DNS, umpama DNS Google 8.8.8.8.